Globalstar Product Management – Technical Support

GSP-1600 Software Version Capability Matrix (TB-02-0219)

leave a comment »

To determine the software (firmware) version of the GSP-1600, press “MENU” “8” “3”

The major features available with the different software versions are shown in Technical Bulletin TB-02-0219.

QUESTION:

I would like to know if there is a new software version for Qualcomm GSP1600.  The version we are using is  R5.3.1.1.0. Is this the latest version?  We have been told that some GSP-1600 phones have a different SW version.

ANSWER:

The short answer is that any phone with an existing software version of R5.3 or lower can ONLY be upgraded to R5.3 software, because that is the newest software for those phones.  These phones are identifiable by the code 10-70695 or 10-C6022 on theHardware Version sticker in the battery compartment.   These phones can use any version of GSP-1600 software between R4.7 and R5.3.  We recommend that ONLY versions R5.2 and R5.3 be used.

If you have any of the latest build of phones, which have R5.4 software on them, those phones must NOT be downgraded to any previous version of software.  They can only utilize R5.4 software.  These phones are identifiable by the code 10-C6165 on the Hardware Version sticker in the battery compartment.

The R5.4 software provides NO new functions beyond R5.3.  The only difference between the R5.3 software and the R5.4 software is the display drivers, because new display driver software was required in order to drive the new display on the new GSP-1600 phones.  The new software version CANNOT be used with older phones.

Because some of the electronics suppliers were no longer making the original components, there were some minor hardware changes in the final production run of GSP-1600 phones.  The display, for example, had to be replaced, as well as some supporting chips.  This required new display drivers.  As a result, Qualcomm had to develop a new software build which utilizes the new display drivers.

The R5.4.0.0.0 software can ONLY be used on phones with the new display, identifiable by the code C6165 on the Hardware Version sticker in the GSP-1600 battery compartment.

R5.4.0.0.0 must NOT be used on any older GSP-1600 phones, because the older phones require the original display driver.

Advertisements

Written by Joseph Crowley

May 3, 2008 at 9:12 am

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: